サポートインフォメーション

不具合情報
2004.03.22

パソコンのOSが使用するUSBホストコントローラの種類によって、通信エラーが発生してしまい、記録データが全てO(ゼロ)となったり、TR-71U/72Uとの通信ができなくなってしまう現象について

T&D Recorder for Windowsにおける問題により 、大変ご迷惑をお掛けしましたことを深くお詫び申し上げます。
本件に関しましては下記の通りご案内致します。

概要

パソコンのOSが使用するUSBホストコントローラの種類によって、通信エラーが発生し、エラーに起因して以下のいずれかの不具合を引き起す場合があることが判明致しました。

1.本体の液晶表示が0.0℃または0%のまま変化せず、記録データも全て0.0℃または0%となる。
2.ch1の記録データが全て0.0℃となり、グラフ表示されない。
3.以前通信できていたUSB通信ができなくなる。(TR-71U/72U本体が認識されない)

お客様には大変ご迷惑をお掛け致しましたことを深くお詫び申し上げます。
つきましては、お客様にお掛けするご迷惑を最小限にすべく、不具合個所を修正したアップデートプログラムを弊社ホームページ上に公開し、プログラムのバージョンアップにて対応させて頂きます。
今後、このようなことがないよう品質向上・管理に一層の努力を重ねて参ります。

発生環境

発生状況

  1. 発生条件
    この問題は、T&D Recorder for Windows Ver.1.20~1.23をご使用になられているPCで発生致します。
    但しこの現象は、全てのパソコンで起きるわけではございません。
  2. 現象
    1.本体の液晶表示が0.0℃または0%のまま変化せず、記録データも全て0.0℃または0%となる。
    2.ch1の記録データが全て0.0℃となり、グラフ表示されない。
    3.以前通信できていたUSB通信ができなくなる。(TR-71U/72U本体が認識されない)
  3. 原因
    上記3件の現象は、同一の原因から発生します。
    USB通信でエラーが発生した際に、本体の設定が異常な値に書き変わってしまうことが原因であり、本体ハードウェアの不具合ではございません。

    【USB通信時に発生するエラーについて】
    通信エラーが起きる原因は、パソコンのOSが使用するUSBホストコントローラとの関係によることが判明致しました。
    パソコンのUSBホストコントローラには、ユニバーサルホストコントローラとオープンホストコントローラの2種類あり、どちらかが使用されています。
    当該バージョンのソフトウェアは、オープンホストコントローラのパソコンに対して記録設定を行った際に、データ転送のタイミングのずれによってエラーとなり、上記不具合を引き起す場合があります。
  4. 対策
    今回リリース致しますT&D Recorder for Windows Ver.1.24へバージョンアップするアップデートプログラムを実行して頂くことで、これらの問題が改善されます。
    本ソフトウェアに「おんどとりTR-71U,TR-72U」を接続することで、上記の現象が起きているかどうかの確認が行える機能を付加致しました。
    早急に本ソフトウェアをインストールして頂きますようお願い致します。 また、全般的にUSB通信を改善しておりますので、全てのお客様にバージョンアップをお勧め致します。

ソフトウェアのインストールと接続テスト

1. インストール手順
ダウンロードページから、ソフトウェアのダウンロードを行い、「tdj1240.exe」をダブルクリックすると、以下の画面が表示されます。


OKをクリックします。
以下のウィンドウが表示されます。


「修正」を選択し、「次へ」をクリックすると、インストールを開始します。
2. 接続テストのお願い
T&D Recorder Ver.1.24を起動して「おんどとりTR-71U,TR-72U」を接続すると、自動的に異常をチェックします。もし異常があった場合、以下のメッセージが表示されます。表示されない場合は、問題ありません。そのままご使用頂くことが可能です。
お手持ちの「おんどとりTR-71U,TR-72U」につきましては、全てこのテストを行ってください。

→メッセージが表示されない場合
設定値に問題はありません。そのままご使用頂くことが可能です。

→メッセージが表示された場合
はい(Y)を押すことによって、異常な設定値のみが工場出荷状態に修正されます。
(この処理により記録データが消去されることはありません。)
ただし、記録間隔は修正されませんのでお客様ご自身で設定をお願いいたします。
また、アジャストメント機能をお使いのお客様は設定値をご確認ください。

→パソコンに接続してもソフトが本体を認識しない場合
この場合に限り、データを吸い上げできる可能性がございます。ご希望のお客様は、弊社営業部宛てご連絡ください。

データが消失しても構わないお客様は、以下の操作を行ってください。
.本体から電池を抜いた状態で20分以上放置し、再度電池を入れ電源をONにして下さい。パソコンと接続して、上記メッセージが表示しなければ正常にご使用できます。
メッセージが表示したら、上記「メッセージが表示された場合」に従ってください。

改めまして、この度多大なご迷惑をお掛け致しましたことを心よりお詫び申し上げます。
これに懲りず今後とも弊社製品をご愛顧いただけますようお願い申し上げます。
お問い合わせ
株式会社ティアンドデイ
〒390-0852  長野県松本市島立817-1
TEL: 0263-40-0131 / FAX: 0263-40-3152